Introduction to Geocortex Essentials Workflow

 

Geocortex Workflow provides a quick and easy way to develop RESTful applications (workflows) that work with Geocortex Essentials. For example, you could create a workflow that produces a report about a set of features that the user selects. When the user runs the workflow, the workflow might start by prompting the user to select some points on the map. The workflow then adds some buffering, performs a server-side query, and returns the list of features found by the query to the viewer. In the viewer, the user selects which features to include in the report. The list of features is returned to the server, where the report is generated, and then sent back to the viewer for display.

Workflows handle many of the low-level complexities associated with software development, like serialization, client-server communication, and coordination of asynchronous processes. This speeds development and frees you to focus on the business problem.

At its simplest, a workflow is a sequence of activities. A simple workflow takes inputs, operates on the inputs, and produces the output. Many GIS workflows fit this pattern.

Geocortex workflows go well beyond this simple model. Geocortex workflows:

Geocortex Workflow Designer

Geocortex Essentials comes with a powerful designer for creating workflows, Workflow Designer.

Geocortex Workflow Designer has many features that facilitate the creation of workflows:

Installation

Workflow Designer is installed when you install Geocortex Essentials.

Launch Workflow Designer

To launch Workflow Designer:

  1. Follow the instructions for the operating system you are using:

Design Interface

Workflow Designer displays a visual representation of your workflow within the design area ( in the screen capture below, labelled ActivityBuilder). To create a workflow, you drag activities from the Activities panel () to the design area () and group them into a logical sequence. Each activity has configurable properties () that govern how the activity behaves and how it relates to other activities. Values are passed from one activity to the next using variables and arguments (). Workflow Designer's built-in simulator allows you to run a simulation of your workflow without having to deploy a host application. Click Start Simulator Start Simulator tool in the ribbon () to open the simulator.

Workflow Designer's design interface

The table below summarizes the main parts of Workflow Designer's design interface. The numbers in the screen capture correspond to the numbers in the table.

Main Parts of the Design Interface

#

Component

Description

Menu bar

The menu bar contains standard File, Edit, and Help menus. In addition, the Edit menu has commands to export the workflow image. The Logging menu allows you set the log levels for the server-side logs.

Ribbon with Search box

The ribbon contains a subset of the commands that are available through the File menu, plus an icon to open the simulator. The ribbon also contains the search tool that you can use to find and highlight elements within a workflow.

Activities panel

The Activities panel lists the activities that you can use in workflows. To add an activity to the workflow you are creating, drag the activity from the Activities panel to the design area. To open the help page for an activity, right-click the activity in the Activities panel and select the Help option.

Activity Builder

The Activity Builder is the design area where you build your workflow. Along the bottom of the design area are tabs that you use to add variables, arguments, and to import namespaces.

Properties

The Properties panel displays all the properties of the currently selected activity and any assigned values.

Variables Tab, Arguments Tab, and Imports Tab

The Variables, Arguments and Imports tabs allow you to create and edit variables and arguments, and to import namespaces and libraries for use within a workflow. To open a tab, click the tab's name.

See also...

Simulator Interface

Navigate a Workflow

The table below lists ways to move around and see different parts of a workflow in Workflow Designer's design area.

Navigate the Workflow Image in Workflow Designer's Design Area

To:

Do this:

Fit the whole workflow image within the existing design area

Click Fit to screen  at the bottom of the design area.

Open and view a nested activity (which could contain other activities)

Double-click the activity in the workflow image. (Do not click within a field.)

Alternatively, right-click the activity and select Open.

Zoom out one or more levels, when viewing a nested activity

Click Expand All or Collapse All at the top of the design area.

Alternatively, click a specific link in the breadcrumb at the top of the design area to go to that part of the workflow.

View the image at 100%

Click Reset zoom to 100%  .

Alternatively, select 100% from the magnification drop-down list  at the bottom of the design area.

Maximize the area available for the image within Workflow Designer

Click Variables / Arguments / Imports at the bottom of the design area to minimize the Variables, Arguments, or Imports area.

Find the currently visible part of the image within the workflow

Click Overview  at the bottom of the display area.

Pan the image

Click Overview  at the bottom of the display area and drag the yellow box in the Overview window.

Alternatively, use the scroll bars.

Zoom in or out a preset amount

Select a zoom level from the magnification drop-down list    at the bottom of the design area.

Alternatively, hold down the Ctrl key and scroll your mouse wheel.

Hide or show nested activities and the properties for all activities

Click Collapse All / Expand All at the top of the design area.

Undo Collapse All or Expand All

Click Restore at the top of the design area.

Workflow Files

Workflows are stored as .xaml files. When you create a workflow in Workflow Designer, you are actually creating a .xaml file. The .xaml file contains all the information needed to run the workflow.

Because they are based on XML, workflows are not compiled. This means that you can inspect and edit a workflow in a text editor or XML editor if you want to.

Workflow Architecture

Geocortex Workflow is based on Microsoft Workflow Foundation 4.0, which is part of the .NET 4.0 stack. Being implemented in .NET on the server has many advantages. The main advantage is that it places the power of Windows Communication Foundation (WCF) and other .NET technologies at your command. Another advantage is having access to the libraries of the .NET Framework, which makes interaction with other systems straightforward. It also allows you to leverage existing knowledge in .NET programming for creating custom activities.

Geocortex Workflow extends Microsoft Workflow Foundation in several ways:

To learn more about Microsoft Workflow Foundation, read A Developer's Introduction to Windows Workflow Foundation (WF) in .NET 4.

© 2019 Latitude Geographics Group Ltd. All Rights Reserved.

Documentation Version 4.11