Geocortex Essentials System Requirements

Hardware Requirements for Essentials Servers

Any computer that can run one of the supported operating systems is compatible with Geocortex Essentials 4.11. If you are going to use Instant Search, you will need a more powerful server. To ensure adequate performance, follow the guidelines given below.

Minimum Requirements for Essentials Servers

More memory and a faster CPU improve Essentials performance. We recommend that your servers surpass the minimum requirements.

Minimum Hardware Requirements for an Essentials Server

Hardware Component

Minimum

Recommended

Random Access Memory (RAM)

4 GB

8 GB or higher

Storage Drive (HDD, SSD)

1 GB

5 GB or higher

CPU

2-core processor,
2 GHz, x64

4-core processor, 2 GHz or higher, x64

Requirements for Servers Running Instant Search

Instant Search is I/O bound. When serving search requests, Instant Search accesses both system memory (RAM) and the storage drive. You can improve the performance of Instant Search by increasing RAM and upgrading the storage drive.

Instant Search is not CPU bound. An upgrade to the server's CPU does not significantly improve the performance of Instant Search.

To improve Instant Search performance:

Hardware Requirements for an Essentials Server Running Instant Search

Hardware Component

Minimum

Recommended

Notes

Random Access Memory (RAM)

6 GB

8 GB or higher

 

Storage Drive (HDD, SSD)

40 GB HDD

100+ GB SSD

As a guideline, the Instant Search index requires about 2 GB of disk space per 1 million features. This ratio varies with feature size.

Software Requirements for Essentials Servers

The software requirements are the same for all servers, whether they are running Geocortex Core and Essentials, or just the REST API. For more information, see Geocortex Essentials Deployment.

Before starting the installation, the installer checks whether the server meets the software requirements. The installer will not install a component if the component's requirements are not met.

Operating System Requirements

Because Essentials is built on Microsoft's .NET Framework, Essentials must be deployed on Microsoft Windows, specifically, on 64-bit Windows.

Essentials supports the following versions of 64-bit Windows:

For Windows Server 2008 R2: Collaboration makes use of web sockets to create rooms. Windows Server 2008 R2 dos not support web sockets. For Collaboration to work, you need to open the port that is used by Collaboration. If you are using SSL, you also need to configure the role to use the correct SSL thumbprint. Finally, you need to configure your viewer to connect directly on the newly opened port, instead of using the web socket. For complete instructions, see the Knowledge Base article Fixing Collaboration when running Essentials on Windows Server 2008 R2 & Windows 7.

.NET Framework Requirements

Geocortex Essentials is built on Microsoft's .NET Framework. Essentials requires .NET Framework 4.5 or newer.

You must download and install the .NET Framework before you can install Essentials. You can download the .NET Framework from the Microsoft Download Center.

Web Server Requirements

Geocortex Essentials requires Internet Information Services (IIS) 7.0 or newer.

Specific IIS components must be enabled. See IIS Configuration for information.

Geocortex Essentials Manager Requirements

Geocortex Essentials Manager runs in a web browser. Manager supports the following browsers:

These browsers are supported in the sense that their use with Manager is tested. Other browsers and browser versions may also work with Manager.

Geocortex Essentials Manager uses cookies. To use Manager, cookies must be enabled in your web browser.

Supported Versions of the Geocortex Viewers

We recommend using Geocortex Viewer for HTML5 2.12 with Geocortex Essentials 4.11.

Running Essentials with older versions of the viewer framework results in reduced viewer capabilities. Running Essentials with newer versions of the viewer may lead to errors and is not recommended either.

Supported Versions of Esri Software

Supported Versions of ArcGIS Enterprise

Geocortex Essentials 4.11 supports ArcGIS Enterprise 10.5 and newer, including ArcGIS Server and Portal for ArcGIS.

Supported Versions of ArcGIS Server

Geocortex Essentials 4.11 supports ArcGIS Server 10.1 to ArcGIS Server 10.4, and ArcGIS Server within ArcGIS Enterprise 10.5 and newer.

Supported Versions of Portal for ArcGIS

Geocortex Essentials 4.11 works with the following versions of Portal for ArcGIS:

© 2019 Latitude Geographics Group Ltd. All Rights Reserved.

Documentation Version 4.11