Upgrade to Core 3.x or Newer Without Upgrading Essentials

We recommend that you upgrade your Geocortex Core version to 3.x or newer to take advantage of its new features. Upgrading to Essentials 4.6 or newer automatically upgrades Core to 3.x or newer. If you want to keep an older version of Essentials, you can upgrade Core without upgrading the Essentials instance that uses it.

The process of updating Geocortex Core differs depending on the version of Geocortex Essentials that you are using currently. It is easier to upgrade Core if you are using Essentials 4.6 than it is to upgrade Core if the version of Essentials is 4.4 or 4.5. The reason for this is that the 4.4 and 4.5 versions of Core require that you run the Geocortex Essentials Legacy Version Compatibility Tool in order to update key files needed to make Essentials compatible with the new Core.

Upgrade to Core 3.x or Newer but Keep Essentials 4.6

To upgrade to Core 3.x or newer and keep Essentials 4.6:

  1. On the server with Essentials, install or update the Analytics Hub or Agent.

    The installation or update automatically updates the existing Core installation and nothing further is required.

Upgrade to Core 3.x or Newer but Keep Essentials 4.4 or 4.5

To upgrade to Core 3.x or newer and keep Essentials 4.4 or 4.5:

  1. On the server with Essentials, install or update the Analytics Hub or Agent.

    The installation or update automatically updates the existing Core installation.

  2. Run the Geocortex Essentials Legacy Version Compatibility Tool for each instance of Essentials that is older than 4.6 on the server.

© 2018 Latitude Geographics Group Ltd. All Rights Reserved.

Documentation Version 1.4